I’m not receiving new document emails

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Symptom

I am not receiving email notifications when a new document is uploaded.

Cause

  1. Your email client may be marking emails from Firmex as junk or spam. Therefore, the new document emails are not arriving at your Inbox.
  2. Document activity notification emails for the project are disabled.
  3. The new document email is being sent from Firmex, it just hasn’t arrived in your Inbox yet.

Solution

Check your spam/junk folder for the email

Check your spam and junk folder for an email containing the subject line “There is new document activity” from the sender @firmexpostmaster.com.

Allow the @firmexpostmaster email domain

Have the user contact their IT administrator and ask that the domain @firmexpostmaster.com be allowed through the company firewall. This will unblock multiple users’ invitations.

Change the frequency of your email notifications

New document emails are sent by Firmex once a week, once a day, once an hour, or as soon as a document is uploaded. To check and change the frequency of your document emails, do the following:

  1. Log in to your Firmex data room.
  2. Once you are logged in, from the top-right corner, click your name. Then, select Email Settings.
  3. Change the frequency of your email notifications. Then, click Save.

Note: A frequency of Immediate will send one email per uploaded document (e.g. 10 emails for 10 documents), so be careful when choosing the Immediate frequency.

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