Planned maintenance: Please be advised that our platform is temporarily unavailable for maintenance on October 18th from 2:00 AM EDT to 7:00 AM EDT.

I am being directed to an expired password link

Symptom

When I click the Set or Reset Password button in the email, it says the link has expired.

Cause

1. The link has expired. A data room invitation link is valid for 7 days, while a password reset link is valid for 1 hour

2. Your email is using a protection service, such as Mimecast or McAfee, which can expire the link upon delivery

Solution

Solution 1. Request a new link by going to the login page and clicking Reset/Forgot Password

Solution 2. Copy and paste the link text (found in email) into your browser.

If you're still having trouble, please call Support at 1-888-688-4042 ext. 11.

 

 

From the Blog

More Virtual Data Room Insights

Can't find what you're looking for?

Get instant answers to the most common questions and learn how to use Firmex like a pro. If you need immediate help, reach our support team 24/7 using the link below:

Submit a Request