Symptom
The user has requested a direct to disk download, but nothing appears to be happening.
Cause
The Firmex DocExchange window is being blocked. The DocExchange is required for the transfer of data from Firmex to your computer.
Solution
Manually bring up the Firmex DocExchange
After you clicked the download button, did a transfer window appear? If not, it may have been blocked by your browser. To manually bring up the transfer window (i.e. DocExchange), from the bottom right-hand corner of your data room, click the “Open in New Window” button.