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I am unable to share files from Firmex FileSend

Symptom

You are logged into Firmex FileSend and the Share button appears to be grey and cannot be clicked.

Cause

Your account is set to “Receive Only” access meaning that you can receive transfers from other users, but cannot send them yourself. This may occur if:

  1. You were added as a recipient of a transfer but your account is not part of a paid team or corporate account.
  2. You were part of a 14 day free trial that has now expired.
  3. You originally were a member of a paid team or corporate account but have now been set to “Receive Only”.

Solution

If you were not previously part of a Free Trial you can try FileSend for 14 days by clicking here.

If your Free Trial has expired you can subscribe to a Team or Corporate FileSend plan.

For assistance with your account please contact Firmex Support.

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